Crear un gif animado de un vídeo en Ubuntu en un solo clic

Crear un gif animado de un vídeo en Ubuntu o en cualquier otra distribución es realmente sencillo, ya sea utilizando el emulador de terminal o bien alguna de las diferentes opciones que existen disponibles.

En un libro, revista, etc, el uso de imágenes animadas, evidentemente no es posible. Sin embargo, en una página web, en las redes sociales, en anuncios, etc, es una solución realmente interesante para atraer la atención del usuario.

Así, ya hace algún tiempo, implementé una sencilla aplicación para crear un gif animado de un vídeo, 2gif.

Crear un gif animado de un vídeo - logo

Crear un gif animado de un vídeo en Ubuntu

2Gif es una sencilla aplicación que nos permitirá crear un gif animado de un vídeo en Ubuntu, utilizando la tecnología Drag & Drop (arrastrar y soltar), y a partir de ahí seleccionar el momento de inicio y el momento de fin del vídeo.

Uso y funcionamiento

Para utilizar 2Gif para crear un gif animado de un vídeo en Ubuntu, solo tienes que iniciarlo desde el Dash o Tablero en Unity, o bien, desde cualquier otro de los lanzadores mas habituales, Plank, Synapse, etc.

Una vez iniciado, veremos un cuadro de diálogo, como el que se muestra a continuación, donde solo tendremos que arrastar el vídeo al cuadro de la derecha, y a continuación seleccionar el instante inicial y el final de la parte con la que queremos crear un gif animado de un vídeo.

Crear un gif animado de un vídeo - ventana principal

El resultado de lo que he indicado se puede ver en la siguiente imagen.

Crear un gif animado de un vídeo - ejemplo

Y una vez procesado el vídeo, se genera una imagen animada con el mismo nombre que el vídeo original, pero con extensión gif, evidentemente.

A partir de aquí, ya depende de ti, donde quieras utilizar la imagen animada; tu página web, en un anuncio, en las redes sociales, etc. Una operación, sencilla, rápida y muy efectiva.

Crear un gif animado de un vídeo - resultado

Instalación

Para instalar 2Gif en Ubuntu, solo tienes que ejecutar las siguientes órdenes en un emulador de terminal,

sudo add-apt-repository ppa:atareao/atareao
sudo apt-get update
sudo apt-get install 2gif

Si te ha gustado el artículo, apúntate y te mantendré actualizado sobre el que es el mejor sistema operativo. Te mostraré como mejorar tu entorno de trabajo y conseguir ser mucho mas productivo

Publicado en la categoría... Apps
Etiquetado como... , , , , ,
  • Xavier Rossich Prades

    Hola,
    como siempre darte las gracias por tantos años ayudándonos.
    Al intentar instalar 2gif, me sale esto:

    sudo apt-get install 2gif

    Leyendo lista de paquetes… Hecho

    Creando árbol de dependencias

    Leyendo la información de estado… Hecho

    No se pudieron instalar algunos paquetes. Esto puede significar que

    usted pidió una situación imposible o, si está usando la distribución

    inestable, que algunos paquetes necesarios no han sido creados o han

    sido movidos fuera de Incoming.

    La siguiente información puede ayudar a resolver la situación:

    Los siguientes paquetes tienen dependencias incumplidas:

    2gif : Depende: ffmpeg pero no es instalable

    E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

    Si pudieses ayudarme estaría muy agradecido.

    • Hola Xavier,
      Gracias a ti por comentar, e indicar el problema, con esto es sencillo para ayudar a otros.

      Que distribución utilizas?

      Un saludo.

      • Xavier Rossich Prades

        Hola, ubuntu 14.04

        • Hola Xavier, ya he descubierto el problema, y se encuentra en el sorporte de Ubuntu a ffmpeg. En la versión 14.04 utilizaban avconv, un fork. Voy a empaquetar de nuevo utilizando esta versión.

          Gracias por tu ayuda.

  • ludikus

    Hola
    Hice el procedimiento como lo indicas pero
    me aparece al final del proceso esto:
    No se pudieron instalar algunos paquetes. Esto puede significar que
    usted pidió una situación imposible o, si está usando la distribución
    inestable, que algunos paquetes necesarios no han sido creados o han
    sido movidos fuera de Incoming.
    La siguiente información puede ayudar a resolver la situación:

    Los siguientes paquetes tienen dependencias incumplidas:
    2gif : Depende: ffmpeg pero no es instalable
    E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

    Me gustaría poder crear un Gif así de fácil como lo comentas, espero que se pueda arreglar el procedimiento, gracias

    • Hola ludikus,

      Que distribución utilizas?

      Un saludo.

      • ludikus

        Perdón por contestar hasta hoy. Uso NetRunner 14.02

        • Hola ludikus,
          Ya está claro, tal y como he comentado con Xavier la solución está en avconv. Lo empaquetaré en los próximos días.

          Saludos.

          • ludikus

            Hola Atareao
            Gracias estaré pendiente
            Saludos

          • He actualizado el paquete…, ya me indicas si te funciona correctamente.

            Gracias y un saludo

          • ludikus

            Hola!
            Te agradezco tu atención, he cambiado de S. O. dejé Ubuntu aproximadamente hace 1 mes ahora estoy usando Kaos, ya no pude usar la aplicación para hacer gifs.
            Saludos, y nuevamente gracias

  • Washington Indacochea Delgado

    Hola Lorenzo saludos, instalé 2gif con su PPA en UbuntuStudio 15.10 x386 pero no funcionó, si lanza pero al arrastrar los videos no pasa nada, no los coje, llega nomás hasta la ventana de la izquierda con la flecha hacia abajo pero no cargan. Yo arrastré videos con estos formatos: .ogv y .mkv. Aquí por defecto está instalado libav-tools-links que tiene avconv, y tengo instalado ffmpeg, y está instalado mplayer2, digo esto por que he leido y parece que algo de ello debe estar instalado

    • Hola @washingtonindacocheadelgado:disqus, déjame que lo revise, a ver que problema puede existir.

      Muchas gracias por el feedback. Un saludo.

  • Hola acabo de intentar instalar y aparece los siguiente:

    sudo apt-get install 2gif
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    No se pudieron instalar algunos paquetes. Esto puede significar que
    usted pidió una situación imposible o, si está usando la distribución
    inestable, que algunos paquetes necesarios no han sido creados o han
    sido movidos fuera de Incoming.
    La siguiente información puede ayudar a resolver la situación:

    Los siguientes paquetes tienen dependencias incumplidas:
    2gif : Depende: ffmpeg pero no es instalable
    E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

    Muchas gracias

    Edito utilizo ubuntu 14.04.4
    Editado nuevamente instale los codec ffmpeg y se solucionó la instalación.

    • Hola Juan Carlos,
      Efectivamente el problema es que utiliza ffmpeg y en la versión 14.04 Ubuntu optó por avconv, voy a empaquetar una nueva versión para 14.04 y así evitaré estos problemas, aunque la solución que has tomado tu es una muy buena solución.
      Gracias por tu aportación. Un saludo.

  • Lincoln Andrade

    Hola estimado como estas….en mi caso instale sin problemas el programa, estoy usando el Mint Rosa….pero cuando intento poner un video en mp4….no pasa nada…quedé colgado como una ampolleta….que puede ser…?

    • Hola Lincoln,

      Lo puedes ejecutar desde un emulador de terminal a ver que error te arroja,

      Muchas gracias y un saludo.

  • Pingback: 9 modos de crear GIFs animados con software libre (Linux, Windows, Mac)()

  • Pingback: Como hacer un GIF animado con software libre: 9 programas diferentes()