De nuevo en Lucid pero sin PAE

Antes de nada quiero agradecer vuestro apoyo. Desde el artículo Lucid Lynx, Karmic Koala y NVIDIA, y tras las ideas aportadas y los incesantes apoyos, he continuado mi búsqueda del camino hacia Lucid Lynx.

Mi equipo es el siguiente, por si a alguien le puede valer mi experiencia:

  • Intel(R) Core(TM)2 Quad  CPU   Q9300  @ 2.50GHz
  • Tarjeta Gráfica NVIDIA GeForce 9600GT 512 RAM
  • 4 Gb de Ram (aunque ahora realmente tengo 3, por lo que explicaré más adelante)
  • SO Ubuntu 10.04 (lucid)
  • Gnome 2.30.2 (Ubuntu 2010-06-25)
  • Kernel 2.6.32-24-generic (antes 2.6.32-24-generic-pae, lo he cambiado como explico más adelante)

Tengo que decir que he hecho una cantidad de pruebas increibles. Vamos he llenado aproximadamente unas diez hojas de anotaciones de lo que iba haciendo para no repetirme, y aún así no tengo claro, que no haya realizado alguna prueba un par de veces.

He intentado instalar el driver de NVIDIA desde los controladores de hardware, desde el driver descargado desde la página de NVIDIA. He modicado xorg.confg en innumerables ocasiones. Me ha pasado de todo, no se cargaba el modulo nvidia, me decía que ya tenía un servidor en funcionamiento, no instalaba el modulo nvidia, solo me funciona noveau, en fin, una verdadera amargura. Estaba desesperado.

Tengo que decir que me había replanteado volver nuevamente a Karmic, pero antes cuando instalé Karmic, me di cuenta del excelente trabajo que había hecho el equipo de Ubuntu para hacer de Lucid, una versión verdaderamente amigable. Hay una salto cualitativo entre las dos versiones. Así que decidí no volver.

Como lo solucione:

Pues, tenía instalada el kernel 2.6.32-24-generic-pae, tengo 4 Gb de RAM,  en algún sitio de los muchos por los que he estado mirando en busca de una solución, encontré alguna relación entre NVIDIA y PAE, y se me encendió una bombillita.

Dije que no probaré con el kernel 2.6.32-24-generic, aunque pierda algo de RAM, a lo mejor… Y efectivamente, cambié el kernel y a funcionar.

No me preguntes ni como ni porque, pero ahora funciona perfectamente. Misterios tiene la vida.

Si te ha gustado el artículo, te invito a que lo compartas con otros, y así me ayudes a su difusión. . Si por lo contrario, no te ha gustado, crees que se puede mejorar, has encontrado algún error, o tienes alguna sugerencia, escribe un comentario o bien envíame un correo.

Publicado en la categoría... Ubuntu
Etiquetado como...

Artículos relacionados

  • Josev

    ¿Y por que no probaste la versión de 64 bits? Yo la tengo y reconoce toda la ram.

    • Invitado

      Tiene razón Josev… el problema PAE es sólo de la arquitectura x86… De todas maneras como dije arriba a mí el “current” -actualmente el 193- me da problemas y tengo que usar el anterior.

      • La verdad es que he hecho muchas pruebas. Ahora no voy a volver a probar. Ya que el equipo funciona, voy a esperar unos días.
        De todas maneras os agradezco vuestros comentarios.

    • Pues la verdad es que ni se me ha pasado por la cabeza. Siempre creí que el de 64 bits solo era para utilizar con procesadores de 64 bits.
      Ahora en otro equipo tengo uno procesador de 64 funcionando con 32, básicamente por que me va mejor.

      • Korrosiv

        Pues yo tengo en casa 3 Core 2 Quad a 2.4 GHz y los tengo todos corriendo con lucid de 64 sin ningún problema. Todos con 4 GB de RAM. Uno con una Nvidia GTX260, otro con una GTX 275, y el último con una GeForce 9800GT. No dejo la versión de 64 ni loco.

      • Aberkoke

        El procesador que tienes por supuesto que soporta 64 bits… es más, no se como no lo has probado… yo hace años que no uso linux de 32 bits, incluso con menos de 4 gigas… la razón muy sencilla, funciona mejor, algunas aplicaciones estan optimizadas para ello y consiguen mayor rendimiento… y no tiene ninguna desventaja… funciona todo perfectamente igual de bien que en 32 bits…. ahh y todos los intel modernos, a partir de los core2 duo son 64 bits. También los AMD64 que vienen a ser procesadores totalmente similares…

  • Invitado

    Siempre probaste con el driver “current”, a mí el “current” me da problemas y tengo que usar el… nvidia-173 173.14.22-0ubuntu11 NVIDIA binary Xorg driver, kernel module and VDPA

    • Pues también lo probé. Es más añadí drivers mas modernos desde un repositorio de Lauchpad, ppa:ubuntu-x-swat/x-updates, con la idea de que esto estuviera resuelto. Pero tampoco.
      Lo que más me llama la atención es que con un kernel tenga problemas y con otro no (me refiero a la misma revisión)

  • fidojones

    Y digo yo, has probado simplemente a poner la linea:

    blacklist nouveau

    En el fichero:

    /etc/modprobe.d/blacklist.conf

    El driver de nvidia no se instala si el modulo de noveau esta cargado. Yo he tenido que hacer eso para que me funcione la nvidia, porque si esta cargado no le deja detectar la tarjeta al driver oficial.

    • También lo probé, pero ni con esas.