De nuevo, liberado Translate-me 0.3.9 para Ubuntu

Nuevamente ha sido un bug, descubierto por Simon (al que le tengo que agraceder su inestimable colaboración), el que me ha llevado a revisar el código siguiendo sus precisas indicaciones.

El problema se encuentra en los caracteres especiales de html, que no son tratados de forma adecuada por Translate-me. Es decir cuando Translate-me se encontraba, por ejemplo con: ‘ aparecía: ' exactamente tal y como refleja la imagen facilitada por Simon para aclarar el bug.

De esta manera, en la nueva versión de Translate-me, se soluciona este problema, haciendo un tratamiento de todos los caracteres especiales html que aparecen en la traducción, quedando el resultado como se espera.

Además he modificado algunos pequeños detalles, para mejorar su integración, como por ejemplo la ubicación del logo en la carpeta que toca «/usr/share/pixmaps», para que sea facilmente localizada.

Otro de los pequeños cambios incorporados, está relacionado con la confección del paquete para Ubuntu, he intentado añadir todas las depencencias de los módulos de Python, que habeis ido informando, y las que he visto yo, aunque no tengo claro que estén todas.

También he ido incorporando las traducciones de Launchpad facilitadas por Enbata (Vasco), Jan Dolejš (Checo), mercier133 (Francés), bigriver9 (Japonés), Eugene Marshal (Ruso), Fitoschido (Español) y zeugma (Turco).

A todos ellos, agradecer su dedicación y esfuerzos y disculparme por no haberlos incorporados en los créditos. De la próxima versión no pasará. Gracias a todos ellos.

Instalación y/o actualización:

Instalación

Lo de siempre, añadir el repositorio:

sudo add-apt-repository ppa:atareao/atareao

actualizar:

sudo apt-get update

e instalar haciendo click en translate-me o desde el terminal:

sudo apt-get install translate-me

10 comentarios en “De nuevo, liberado Translate-me 0.3.9 para Ubuntu

  1. Soy un usuario normal de Ubuntu y un fiel seguidor de Translate-me. Lo considero el mejor traductor en línea del motor Google Translate. Felicitaciones y muchas gracias por toda la dedicación a nosotros.

    1. Me aparecen estas líneas al instalarlo:

      pedro@pedro-X456UQ:~$ sudo apt-get install translate-me
      Reading package lists… Done
      Building dependency tree
      Reading state information… Done
      E: Unable to locate package translate-me

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *